Misafir Kullanıcı 14 Ağustos 2021 385

İki Tarih Arasındaki Sayıların Adetlerini Nasıl Bulurum

Excel sayfamdaki bir sütunda tarihler, hemen yan sütununda ise sayı ve metin değerlerinin karışık olarak yer aldığı veriler bulunmaktadır.

Ben, belirlediğim iki tarih arasındaki sadece sayısal değerlerin adetini bulmak istiyorum. Bunun için nasıl bir formül ya da makro yazmam gerekir. Destek olursanız sevinirim.

Teşekkürler.
EXCEL DEPO 10 ay önce

Merhaba,

Sorunuzdan yola çıkarak hazırladığım basit adımlar ile şu şekilde sonuca ulaştım:

  1. A1:A9 aralığına 01.01.2021'den itibaren rastgele tarihler yazdım.
  2. B1:B9 aralığına hem sayısal hem metin içeren değerler yazdım.
  3. C1 hücresine:
    =EĞER(YADA(A1:A9>="01.01.2021";A1:A9<="31.01.2021");TOPLA(--(ESAYIYSA($B$1:$B$9)));0)
    formülünü yazarak, 1 Ocak ile 31 Ocak arasında tarihlere ait kaç sayı olduğunu saymış oldum.
Sütun ve tarih değerlerini kendi ihtiyacınıza göre revize edebilirsiniz.

Backlink Reklam Bu alanda 50 karakterlik açıklama ile web sitenize ait Backlink Reklam yayınlayabilirsiniz.

Yükleniyor...
-->